MKE1 Upstream Provider Outage

Incident Report for CyberLynk Network

Resolved

The upstream provider reports that splicing is complete, and we have confirmed traffic is flowing across the affected circuit. This issue is now resolved.
Posted Aug 07, 2026 - 19:17 CDT

Update

The upstream provider has determined that approximately 300 feed of fiber needs to be replaced.
Posted Aug 07, 2026 - 14:16 CDT

Update

The upstream providers splice team is working to isolate the fault in a 144-count fiber cable.
Posted Aug 06, 2026 - 19:35 CDT

Update

The upstream provider continues to work on the issue. We will provide updates as we receive them.
Posted Aug 05, 2026 - 16:59 CDT

Identified

The upstream provider has identified the issue.
Posted Aug 05, 2026 - 12:58 CDT

Investigating

One of our upstream providers in our Milwaukee data center is experiencing a regional outage and we are following their updates as they address the issue. Customers traversing this provider may have experienced a latency spike as traffic was automatically rerouted over our other providers.
Posted Aug 05, 2026 - 12:14 CDT
This incident affected: MKE1 Core Datacenter Infrastructure.